using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GET_DICTIONARY(.*\n){2}(.*MTS.*)";
string input = @"{
""action"": ""Handler:GET_DICTIONARY"",
""locale"": ""en"",
""data"": {""dictionary_type"":""MTS""}
}
{ ""action"": ""Handler:GET_DICTIONARY"",
""locale"": ""en"",
""data"": {""dictionary_type"":""MTS""}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}