$re = '/GET_DICTIONARY(.*\n){2}(.*MTS.*)/m';
$str = '{
"action": "Handler:GET_DICTIONARY",
"locale": "en",
"data": {"dictionary_type":"MTS"}
}
{ "action": "Handler:GET_DICTIONARY",
"locale": "en",
"data": {"dictionary_type":"MTS"}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);