// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\S\r\n]{2,}").unwrap();
let string = "PoE Port Info','1 up medium Auto Class Searching 0 0.0 0 0.0','10 up low User defined 4(W) Searching - 0.0 0 0.0
10 up low User defined 4(W) Searching - 0.0 0 0.0
";
let substitution = "|||";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}