import Foundation
let pattern = #"[^\S\r\n]{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PoE Port Info','1 up medium Auto Class Searching 0 0.0 0 0.0','10 up low User defined 4(W) Searching - 0.0 0 0.0
10 up low User defined 4(W) Searching - 0.0 0 0.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|||"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)