#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-]?\d*\.\d+|[-]?\d+"
Local $sString = "This is number extract test." & @CRLF & _
"There are 3 types of numbers here." & @CRLF & _
"First type is integer: like 345 or -343." & @CRLF & _
"Second is float like 12.3, 15.329 or -34.2." & @CRLF & _
"Third is portion like .342 or -.532." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")