// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[-]?\d*\.\d+|[-]?\d+").unwrap();
let string = "This is number extract test.
There are 3 types of numbers here.
First type is integer: like 345 or -343.
Second is float like 12.3, 15.329 or -34.2.
Third is portion like .342 or -.532.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}