use strict;
my $str = 'This is number extract test.
There are 3 types of numbers here.
First type is integer: like 345 or -343.
Second is float like 12.3, 15.329 or -34.2.
Third is portion like .342 or -.532.
';
my $regex = qr/[-]?\d*\.\d+|[-]?\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}