package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-]?\d*\.\d+|[-]?\d+`)
var str = `This is number extract test.
There are 3 types of numbers here.
First type is integer: like 345 or -343.
Second is float like 12.3, 15.329 or -34.2.
Third is portion like .342 or -.532.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}