re = /[-]?\d*\.\d+|[-]?\d+/m
str = 'This is number extract test.
There are 3 types of numbers here.
First type is integer: like 345 or -343.
Second is float like 12.3, 15.329 or -34.2.
Third is portion like .342 or -.532.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end