using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-]?\d*\.\d+|[-]?\d+";
string input = @"This is number extract test.
There are 3 types of numbers here.
First type is integer: like 345 or -343.
Second is float like 12.3, 15.329 or -34.2.
Third is portion like .342 or -.532.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}