#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*\.[a-z]+\/?(?:[\w]+(?:\/[\w]+)*)*)"
Local $sString = "http://stackoverflow.co.th" & @CRLF & _
"http://stackoverflow.com" & @CRLF & _
"http://stackoverflow.co.th/" & @CRLF & _
"http://stackoverflow.com/" & @CRLF & _
"http://stackoverflow.com/a/" & @CRLF & _
"http://stackoverflow.com/questions/" & @CRLF & _
"http://stackoverflow.com/questions/12345" & @CRLF & _
"http://stackoverflow.com/12345/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")