using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\.[a-z]+\/?(?:[\w]+(?:\/[\w]+)*)*)";
string input = @"http://stackoverflow.co.th
http://stackoverflow.com
http://stackoverflow.co.th/
http://stackoverflow.com/
http://stackoverflow.com/a/
http://stackoverflow.com/questions/
http://stackoverflow.com/questions/12345
http://stackoverflow.com/12345/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}