re = /(.*\.[a-z]+\/?(?:[\w]+(?:\/[\w]+)*)*)/
str = 'http://stackoverflow.co.th
http://stackoverflow.com
http://stackoverflow.co.th/
http://stackoverflow.com/
http://stackoverflow.com/a/
http://stackoverflow.com/questions/
http://stackoverflow.com/questions/12345
http://stackoverflow.com/12345/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end