import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\.[a-z]+\\/?(?:[\\w]+(?:\\/[\\w]+)*)*)";
final String string = "http://stackoverflow.co.th\n"
+ "http://stackoverflow.com\n"
+ "http://stackoverflow.co.th/\n"
+ "http://stackoverflow.com/\n"
+ "http://stackoverflow.com/a/\n"
+ "http://stackoverflow.com/questions/\n"
+ "http://stackoverflow.com/questions/12345\n"
+ "http://stackoverflow.com/12345/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}