$re = '/(.*\.[a-z]+\/?(?:[\w]+(?:\/[\w]+)*)*)/';
$str = 'http://stackoverflow.co.th
http://stackoverflow.com
http://stackoverflow.co.th/
http://stackoverflow.com/
http://stackoverflow.com/a/
http://stackoverflow.com/questions/
http://stackoverflow.com/questions/12345
http://stackoverflow.com/12345/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);