// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*\.[a-z]+\/?(?:[\w]+(?:\/[\w]+)*)*)").unwrap();
let string = "http://stackoverflow.co.th
http://stackoverflow.com
http://stackoverflow.co.th/
http://stackoverflow.com/
http://stackoverflow.com/a/
http://stackoverflow.com/questions/
http://stackoverflow.com/questions/12345
http://stackoverflow.com/12345/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}