using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"istio_*";
string input = @"istio_agent_go_gc_duration_seconds{quantile=""0""} 7.754e-05
istio___________agent_go_gc_duration_seconds{quantile=""0""} 7.754e-05
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}