const regex = /istio_*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('istio_*', 'gm')
const str = `istio_agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
istio___________agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}