package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)istio_*`)
var str = `istio_agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
istio___________agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}