$re = '/istio_*/m';
$str = 'istio_agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
istio___________agent_go_gc_duration_seconds{quantile="0"} 7.754e-05
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);