// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)istio_*").unwrap();
let string = "istio_agent_go_gc_duration_seconds{quantile=\"0\"} 7.754e-05
istio___________agent_go_gc_duration_seconds{quantile=\"0\"} 7.754e-05
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}