import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "istio_*";
final String string = "istio_agent_go_gc_duration_seconds{quantile=\"0\"} 7.754e-05\n"
+ "istio___________agent_go_gc_duration_seconds{quantile=\"0\"} 7.754e-05\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}