#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:\$\s*(?:\d+(?:\,\d+)?)|(\d+(?:[ -]\d+)+\.?|\d{3,}))(?!\S)"
Local $sString = "123456" & @CRLF & _
"1234567890" & @CRLF & _
"12345" & @CRLF & _
"" & @CRLF & _
"12,123" & @CRLF & _
"1-2-3" & @CRLF & _
"$1" & @CRLF & _
"$12,123" & @CRLF & _
"$123654, $ 123654" & @CRLF & _
"" & @CRLF & _
"123-456-789" & @CRLF & _
"123-456-789." & @CRLF & _
"123-456" & @CRLF & _
"123 456" & @CRLF & _
"123 456 789" & @CRLF & _
"123 456 789." & @CRLF & _
"123 456 123 456 789" & @CRLF & _
"123" & @CRLF & _
"456" & @CRLF & _
"123" & @CRLF & _
"456" & @CRLF & _
"789" & @CRLF & _
"" & @CRLF & _
"$123654" & @CRLF & _
"$ 123654" & @CRLF & _
"12,4569" & @CRLF & _
"123*123*7732" & @CRLF & _
"123h434k5454"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")