using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:\$\s*(?:\d+(?:\,\d+)?)|(\d+(?:[ -]\d+)+\.?|\d{3,}))(?!\S)";
string input = @"123456
1234567890
12345
12,123
1-2-3
$1
$12,123
$123654, $ 123654
123-456-789
123-456-789.
123-456
123 456
123 456 789
123 456 789.
123 456 123 456 789
123
456
123
456
789
$123654
$ 123654
12,4569
123*123*7732
123h434k5454";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}