# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(?:\$\s*(?:\d+(?:\,\d+)?)|(\d+(?:[ -]\d+)+\.?|\d{3,}))(?!\S)"
test_str = ("123456\n"
"1234567890\n"
"12345\n\n"
"12,123\n"
"1-2-3\n"
"$1\n"
"$12,123\n"
"$123654, $ 123654\n\n"
"123-456-789\n"
"123-456-789.\n"
"123-456\n"
"123 456\n"
"123 456 789\n"
"123 456 789.\n"
"123 456 123 456 789\n"
"123\n"
"456\n"
"123\n"
"456\n"
"789\n\n"
"$123654\n"
"$ 123654\n"
"12,4569\n"
"123*123*7732\n"
"123h434k5454")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.