$re = '/(?<!\S)(?:\$\s*(?:\d+(?:\,\d+)?)|(\d+(?:[ -]\d+)+\.?|\d{3,}))(?!\S)/m';
$str = '123456
1234567890
12345
12,123
1-2-3
$1
$12,123
$123654, $ 123654
123-456-789
123-456-789.
123-456
123 456
123 456 789
123 456 789.
123 456 123 456 789
123
456
123
456
789
$123654
$ 123654
12,4569
123*123*7732
123h434k5454';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);