use strict;
my $str = '123456
1234567890
12345
12,123
1-2-3
$1
$12,123
$123654, $ 123654
123-456-789
123-456-789.
123-456
123 456
123 456 789
123 456 789.
123 456 123 456 789
123
456
123
456
789
$123654
$ 123654
12,4569
123*123*7732
123h434k5454';
my $regex = qr/(?<!\S)(?:\$\s*(?:\d+(?:\,\d+)?)|(\d+(?:[ -]\d+)+\.?|\d{3,}))(?!\S)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}