import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:\\$\\s*(?:\\d+(?:\\,\\d+)?)|(\\d+(?:[ -]\\d+)+\\.?|\\d{3,}))(?!\\S)";
final String string = "123456\n"
+ "1234567890\n"
+ "12345\n\n"
+ "12,123\n"
+ "1-2-3\n"
+ "$1\n"
+ "$12,123\n"
+ "$123654, $ 123654\n\n"
+ "123-456-789\n"
+ "123-456-789.\n"
+ "123-456\n"
+ "123 456\n"
+ "123 456 789\n"
+ "123 456 789.\n"
+ "123 456 123 456 789\n"
+ "123\n"
+ "456\n"
+ "123\n"
+ "456\n"
+ "789\n\n"
+ "$123654\n"
+ "$ 123654\n"
+ "12,4569\n"
+ "123*123*7732\n"
+ "123h434k5454";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}