const regex = new RegExp('(?<!\\S)(?:\\$\\s*(?:\\d+(?:\\,\\d+)?)|(\\d+(?:[ -]\\d+)+\\.?|\\d{3,}))(?!\\S)', 'gm')
const str = `123456
1234567890
12345
12,123
1-2-3
\$1
\$12,123
\$123654, \$ 123654
123-456-789
123-456-789.
123-456
123 456
123 456 789
123 456 789.
123 456 123 456 789
123
456
123
456
789
\$123654
\$ 123654
12,4569
123*123*7732
123h434k5454`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}