import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((.*)\\)";
final String string = "[2021-08-30T13:24:38.486063+00:00] technical.INFO: Webhook \"c5179c0a-96cb-49b6-96de-9a70facdcf72\" (card.options) has been handle. ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}