// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((.*)\)").unwrap();
let string = "[2021-08-30T13:24:38.486063+00:00] technical.INFO: Webhook \"c5179c0a-96cb-49b6-96de-9a70facdcf72\" (card.options) has been handle. ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}