using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*>(*SKIP)(*FAIL)|""";
string substitution = @""";
string input = @"Lorem ipsum dolor sit amet, ""consetetur"" sadipscing elitr.
<ul>
<li>At vero eos et accusam et justo</li
<li>Stet clita ""kasd"" gubergren</li>
</ul>
<a href=""https://www.google.com/"" target=""_blank"">https://www.google.com/</a>
""At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet.""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}