$re = '/<a[^>]*>(*SKIP)(*FAIL)|"/m';
$str = 'Lorem ipsum dolor sit amet, "consetetur" sadipscing elitr.
<ul>
<li>At vero eos et accusam et justo</li
<li>Stet clita "kasd" gubergren</li>
</ul>
<a href="https://www.google.com/" target="_blank">https://www.google.com/</a>
"At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet."';
$subst = """;
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;