import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*>(*SKIP)(*FAIL)|\"";
final String string = "Lorem ipsum dolor sit amet, \"consetetur\" sadipscing elitr.\n\n"
+ "<ul>\n"
+ "<li>At vero eos et accusam et justo</li\n"
+ "<li>Stet clita \"kasd\" gubergren</li>\n"
+ "</ul>\n\n"
+ "<a href=\"https://www.google.com/\" target=\"_blank\">https://www.google.com/</a>\n\n\n"
+ "\"At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet.\"";
final String subst = """;
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}