# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B[a-zA-Z'-]+|\W+//gm;t' <<< "MY HOSPITAL'S NAME"