use strict;
my $str = 'MY HOSPITAL\'S NAME';
my $regex = qr/\B[a-zA-Z'-]+|\W+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";