using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B[a-zA-Z'-]+|\W+";
string substitution = @"";
string input = @"MY HOSPITAL'S NAME";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}