import re
regex = re.compile(r"\B[a-zA-Z'-]+|\W+", flags=re.MULTILINE)
test_str = "MY HOSPITAL'S NAME"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)