$re = '/\B[a-zA-Z\'-]+|\W+/m';
$str = 'MY HOSPITAL\'S NAME';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;