using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[+?0?0?966]+)(?:\s?\d{2})(?:\s?\d{7}))$";
string input = @"+966533333333
+966 53 3333333
??????????? 000000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}