import re
regex = re.compile(r"^((?:[+?0?0?966]+)(?:\s?\d{2})(?:\s?\d{7}))$", flags=re.MULTILINE)
test_str = ("+966533333333\n"
"+966 53 3333333\n"
"??????????? 000000000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")