package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:[+?0?0?966]+)(?:\s?\d{2})(?:\s?\d{7}))$`)
var str = `+966533333333
+966 53 3333333
??????????? 000000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}