// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:[+?0?0?966]+)(?:\s?\d{2})(?:\s?\d{7}))$").unwrap();
let string = "+966533333333
+966 53 3333333
??????????? 000000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}