using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>(?!\/(?>test|abc|kimochi)\/).)+?$";
string input = @"https://domain.com/test/link
https://domain.com/abc/link
https://domain.com/kimochi/link
https://domain.com/testa/link
https://domain.com/sad-test-sad/link
https://domain.com/a-abc/link
https://domain.com/akimochi/link";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}