$re = '/^(?>(?!\/(?>test|abc|kimochi)\/).)+?$/m';
$str = 'https://domain.com/test/link
https://domain.com/abc/link
https://domain.com/kimochi/link
https://domain.com/testa/link
https://domain.com/sad-test-sad/link
https://domain.com/a-abc/link
https://domain.com/akimochi/link';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);