use strict;
my $str = 'https://domain.com/test/link
https://domain.com/abc/link
https://domain.com/kimochi/link
https://domain.com/testa/link
https://domain.com/sad-test-sad/link
https://domain.com/a-abc/link
https://domain.com/akimochi/link';
my $regex = qr/^(?>(?!\/(?>test|abc|kimochi)\/).)+?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}