import Foundation
let pattern = #"^(?>(?!\/(?>test|abc|kimochi)\/).)+?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://domain.com/test/link
https://domain.com/abc/link
https://domain.com/kimochi/link
https://domain.com/testa/link
https://domain.com/sad-test-sad/link
https://domain.com/a-abc/link
https://domain.com/akimochi/link
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)