import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?!\\/(?>test|abc|kimochi)\\/).)+?$";
final String string = "https://domain.com/test/link\n\n"
+ "https://domain.com/abc/link\n\n"
+ "https://domain.com/kimochi/link\n\n"
+ "https://domain.com/testa/link\n\n"
+ "https://domain.com/sad-test-sad/link\n\n"
+ "https://domain.com/a-abc/link\n\n"
+ "https://domain.com/akimochi/link";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}