re = /^(?>(?!\/(?>test|abc|kimochi)\/).)+?$/m
str = 'https://domain.com/test/link
https://domain.com/abc/link
https://domain.com/kimochi/link
https://domain.com/testa/link
https://domain.com/sad-test-sad/link
https://domain.com/a-abc/link
https://domain.com/akimochi/link'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end