# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<![\\])['"])((?:.(?!(?<![\\])\1))*.?)\1//g;t' <<< "/a:\"value\" -big=\"this -test:1\\"23 is & $#@ _ y\\"\\"our life\" -test=th_3"